VisIt

From CC Doc
Jump to navigation Jump to search
This page is a translated version of the page VisIt and the translation is 100% complete.
Other languages:
English • ‎français

Visualisation client-serveur

La même version majeure doit être installée sur le client local et sur l'ordinateur hôte à distance; dans le cas contraire, certaines incompatibilités peuvent empêcher la connexion client-serveur.

Sélectionnez l'onglet approprié.

Visualisation client-serveur avec Cedar, Graham et Béluga


Plusieurs versions de VisIt sont installées sur nos grappes; pour connaître les numéros des versions, lancez module spider visit. Pour utiliser VisIt à distance en mode client-serveur, votre ordinateur doit avoir la même version majeure que l'ordinateur hôte, soit 2.12.x ou 2.13.x ou 3.2.x. Avant de démarrer VisIt, téléchargez le fichier de profil XML host_cedar.xml; ce fichier de configuration sert à vous connecter à VisIt 3.2.1.

  • Sous Linux et Mac, copiez le fichier dans ~/.visit/hosts/.
  • Sous Windows, copiez le fichier dans My Documents\VisIt 3.2.1\hosts ou dans le répertoire similaire. Lancez VisIt sur votre ordinateur. Dans le menu principal, sous Options -> Host Profiles, vous devriez voir le profil hôte cedar. Pour effectuer un rendu sur Graham, utilisez
Host nickname = graham
Remote host name = graham.computecanada.ca

Entrez votre nom d'utilisateur tel que défini dans la base de données CCDB.

Username = yourOwwUserName

À l'exception du nom d'utilisateur, votre configuration devrait être semblable à ceci :

HostSetting.png

En cliquant sur Launch Profiles, les profils login et slurm devraient se trouver dans la liste.

LaunchProfiles.png

  • Le profil login est utilisé dans un nœud de connexion, ce qui n'est pas recommandé pour les visualisations intensives.
  • Le profil slurm est utilisé pour une tâche interactive dans un nœud de calcul. Si vous sélectionnez ce profil, cliquez sur l'onglet Parallel puis sur l'onglet Advanced dessous. Dans le champ Launcher arguments, remplacez --account=def-someuser par votre allocation par défaut, comme montré ci-dessous.
  • Sur Cedar uniquement, ajoutez l'indicateur --chdir=/scratch/username avec votre nom d'utilisateur pour lancer votre tâche à partir de votre répertoire /scratch.

LauncherArguments.png

Enregistrez les paramètres en cliquant sur Options -> Save Settings et relancez VisIt pour activer la configuration. Dans le dialogue d'ouverture de fichier, remplacez le nom de l'hôte local par cedar ou graham, selon le cas. La connexion devrait s'établir, le Component Launcher devrait démarrer dans le nœud de connexion et vous devriez voir le système de fichiers de la grappe où vous pourrez localiser et sélectionner un fichier. À l'invite, vous devrez sélectionner le profil login (pour un rendu dans un nœud de connexion) ou slurm (pour un rendu par une tâche interactive dans un nœud de calcul). Dans ce dernier cas, indiquez le nombre de processeurs, le nombre de nœuds et le temps d'exécution, comme dans cet exemple :

SelectProfile.png

Cliquez sur OK et attendez que le moteur VisIt soit en marche. Si le rendu doit s'effectuer sur un nœud de calcul, le temps d'attente peut être plus long. Une fois que le jeu de données est affiché dans Active source, le moteur fonctionne et vous pouvez commencer à travailler sur votre graphe.

Visualisation client-serveur avec Niagara

Configuration de l'hôte

Pour que VisIt puisse se connecter à la grappe, vous devez configurer votre ordinateur hôte par une des méthodes suivantes :

Fichier de configuration

Téléchargez et enregistrez le fichier host_niagara.xml.

  • Sous Linux et Mac, copiez le fichier dans ~/.visit/hosts/.
  • Sous Windows, copiez le fichier dans My Documents\VisIt 2.13.0\hosts\.

Redémarrez VisIt et vérifiez que le profil pour Niagara se trouve sous Options -> Host Profiles.

Configuration manuelle

Lanzez VisIt sur votre ordinateur. Dans le menu Options, cliquez sur Host Profiles; cliquez sur New Host et sélectionnez

Host nickname = niagara
Remote host name = niagara.scinet.utoronto.ca
Username = Enter_Your_OWN_username_HERE
Path to VisIt installation = /scinet/niagara/software/2018a/opt/base/visit/2.13.1

Sélectionnez Tunnel data connections through SSH et cliquez sur Apply.

Visit niagara-01.png

Dans le haut de la fenêtre, cliquez sur Launch Profiles pour créer un profil:

  • login pour utiliser un nœud de connextion et accéder aux données;
  • slurm pour utiliser un nœud de calcul comme moteur de rendu.


Sous l'onglet Parallel sélectionnez Launch parallel engine. Pour un profil Slurm, vous devrez configurer les paramètres.


Visit niagara-02.png Visit niagara-03.png


Lorsque vous avez terminé, enregistrez les modifications avec Options -> Save settings; elles seront en vigueur la prochaine fois que vous lancerez VisIt.

Visualisation client-serveur sur le cloud

Prérequis

La page Cloud : Guide de démarrage décrit la création d'une instance. Une fois connecté à l’instance, vous devrez installer certains paquets pour pouvoir compiler ParaView et VisIt; par exemple, sur une instance CentOS,

 sudo yum install xauth wget gcc gcc-c++ ncurses-devel python-devel libxcb-devel
 sudo yum install patch imake libxml2-python mesa-libGL mesa-libGL-devel
 sudo yum install mesa-libGLU mesa-libGLU-devel bzip2 bzip2-libs libXt-devel zlib-devel flex byacc
 sudo ln -s /usr/include/GL/glx.h /usr/local/include/GL/glx.h

Si vous avez votre propre paire de clés SSH (et non la clé générée par OpenStack pour le nuage), vous pourriez copier la clé publique dans l'instance pour simplifier la connexion; pour ce faire, lancez la commande suivante sur votre ordinateur :

 cat ~/.ssh/id_rsa.pub | ssh -i ~/.ssh/cloudwestkey.pem centos@vm.ip.address 'cat >>.ssh/authorized_keys'

Compilation avec OSMesa

En mode non interactif, le rendu peut être effectué avec un seul script :

wget http://portal.nersc.gov/project/visit/releases/2.12.1/build_visit2_12_1
chmod u+x build_visit2_12_1
./build_visit2_12_1 --prefix /home/centos/visit --mesa --system-python \
   --hdf4 --hdf5 --netcdf --silo --szip --xdmf --zlib

Ceci peut nécessiter quelques heures. L’installation peut ensuite être testée avec

~/visit/bin/visit -cli -nowin

ce qui devrait lancer un interpréteur Python.

Mode client-serveur

Sur votre ordinateur, démarrez VisIt. Sous Options -> Host profiles, modifiez les paramètres suivants : le nom de la connexion, le nom de l'instance hôte, le chemin vers VisIt (/home/centos/visit), votre nom d'utilisateur. Activez enfin le lien SSH. N’oubliez pas de sauvegarder les paramètres avec Options -> Save Settings. En ouvrant un fichier (File -> Open file... -> Host = Arbutus), vous devriez voir le système de fichiers de l’instance. Chargez et visualisez un fichier. Le traitement des données et le rendu devraient s’effectuer sur l’instance alors que le résultat et les contrôles de l’interface utilisateur seront affichés sur votre ordinateur.